Tuesday, 21 August 2007

11G JDBC driver ojdbc5.jar and ojdbc6.jar

After installing 11g on linux you will find that the JDBC 11g driver is shipped as two files and ojdbc14.jar is no longer in there.

  • $ORACLE_HOME/jdbc/lib/ojdbc5.jar - JDK 1.5
  • $ORACLE_HOME/jdbc/lib/ojdbc6.jar - JDK 1.6
So if your using JDK 1.5 use ojdbc5.jar and if using JDK 1.6 use ojdbc6.jar. JDK 1.4 is no longer supported for the 11g drivers so thats the reason no ojdbc14.jar exists now for 11g. The documentation below clearly specifies support for JDK 1.4 is no longer available in the 11g JDBC drivers.
http://download.oracle.com/docs/cd/B28359_01/java.111/b31224/getsta.htm#i1008205

2 comments:

Anonymous said...

Is it ojdbc15.jar & ojdbc16.jar or ojdbc5.jar & ojdbc6.jar for jdk 1.5 and 1.6 respectively?

The description states 15.jar & 16.jar but the name of the jar file is listed as 5.jar and 6.jar.

Could you please clarify/update.

Pas Apicella said...

Yes I corrected it , thanks for pointing it out. The file names are as follows:

$ORACLE_HOME/jdbc/lib/ojdbc5.jar - JDK 1.5
$ORACLE_HOME/jdbc/lib/ojdbc6.jar - JDK 1.6